netroadshow

System Requirements

NOTE: If you work in a corporate environment, please review Important Information for Corporate Users.

In order to view a NetRoadshow webcast, you must have a compatible computer, an Internet connection, a standard browser, and streaming media player. For specific system requirements, see the table below under System Requirements.

Click here to see if your system is configured to view NetRoadshow presentations.
Player

The two streaming players supported by NetRoadshow on Windows systems are Windows Media Player and Adobe Flash. On Macintosh systems, the Adobe Flash Player is supported. These players are available for free and can be downloaded from the sites listed below. You only need to have one of these players installed on your computer in order to view a NetRoadshow.

Windows Media Player: http://www.microsoft.com/windows/windowsmedia/download/
Adobe Flash Player: http://www.adobe.com/go/getflashplayer
Note: You only need one of the above players. Should you be unable to install either one of the above players or you have any difficulty using either player, you can still experience a NetRoadshow presentation using the telephone option.

Password

You will also need a password in order to access a specific webcast, which you must obtain from a representative of the investment bank managing the deal whose webcast you wish to view.

System Requirements for Windows
Component Minimum Required Recommended
Operating System Windows 2000, XP, Vista, 7, or 8 Windows XP or 7
Internet browser Microsoft Internet Explorer 6.0, Mozilla Firefox 2.0, or Google Chome 10.0 Microsoft Internet Explorer 8 or 9, or Mozilla Firefox 3.0 or higher, or Google Chrome 10.0 or higher
Streaming Player Windows Media Player 7.1, or Adobe Flash 9 * Windows Media Player 7.1 or higher, or Flash 9 or higher *
Processor Pentium II class (or equivalent) processor, running at 333 MHz or faster Pentium III class (or equivalent) processor, running at 500 MHz or faster
RAM 128 MB 256 MB or more
Modem 56 kbps Cable/DSL modem or T1 connection
Sound card 16-bit sound card (for streaming audio/video presentations) ** 16-bit sound card or better **
Video display 800×600 pixels at 16-bit color 1024×768 pixels at 24-bit color, or better
* Windows Media Player is not supported in Firefox or Chrome. Click here for more information on media player support in Firefox and Chrome.
** A sound card is not required to view the telephone version of a NetRoadshow presentation.

 

 

System Requirements for Macintosh
Component Minimum Required Recommended
Operating System Mac OS X Mac OS X
Internet browser Safari 2.0, or Firefox 2.0, or Chrome 10.0 Safari 2.0, or Firefox 3.0 or higher, or Chrome 10.0 or higher
Streaming Player Adobe Flash 9 Adobe Flash 9 or higher
Processor PowerPC 800 MHz or faster, or Intel Pentium 800 MHz or faster PowerPC 800 MHz or faster, or Intel Pentium 800 MHz or faster
RAM 128 MB 256 MB or more
Modem 56 kbps Cable/DSL modem or T1 connection
Sound card 16-bit sound card (for streaming audio/video presentations) * 16-bit sound card or better *
Video display 800×600 pixels at 16-bit color 1024×768 pixels at 24-bit color, or better
* A sound card is not required to view the telephone version of a NetRoadshow presentation.

If you do not have a sound card or speakers, are unable to install either of the players, have difficulty using either player, or if you have other technical problems receiving streaming audio and video over the Internet, you will still be able to experience a NetRoadshow presentation using the telephone option.

Full Web browser installations are recommended (not just standard or basic installation packages).

Streaming media players must be installed after Web browser(s) are installed.

Configurations outside of the limitations shown above may or may not work.

ADDITIONAL NOTES FOR MAC USERS:

Due to the lack of support for the Adobe Reader Plugin in Firefox, only documents without security in place are viewable when accessing a presentation in Firefox. Secured Documents are only viewable in Safari with the Adobe Reader Plugin installed.

It is strongly recommended to install the latest versions available of the Adobe Flash Player, and Adobe Reader for Mac users. Both plugins are available for free from Adobe’s website at www.adobe.com.

Does this solve your problem? If not see some other options below.

Related Topics

← Back To Help Home

Copyright © 2006-2014 NetRoadshow, Inc. All rights reserved. Privacy Policy